Nov 2, 2012

Switching-Ether


Switching - EtherChannels

We have covered that I would consider the basics of switching. We've seen how to make a switchport an access port that an end user would connect to. We've setup trunks between switches utilizing DTP and with static configurations. We've taken a basic look at 802.1q, we've created a router-on-a-stick so we could route traffic between vlans, and we've setup VTP so we could tell all out network switches about vlans. Now let's get into some of the advanced topics. I'll start with EtherChanneling and go from there.
EtherChanneling, also know as PortChanneling, is taking multiple links and creating a single logical link. This is mostly for spanning-tree benefit. I won't go over STP as this blog is about etherchannels and not STP. If you have questions on STP feel free to shoot me a message.
There are 3 types of EtherChannels, 1)static 2)PAgP 3)LACP. Static is just creating an etherchannel and putting it in the on mode. PAgP is the Cisco proprietary negotiation method of creating an etherchanel and LACP is the IEEE standard method of etherchannel negotiation. When using one of the etherchannel negotiation methods PAgP and LACP these act similar to DTP in that at least one end needs to be desireable or active. The other end can be in auto or passive, but if both ends are auto or passive then neither side will start the etherchannel negotiation.

MPLS & VRF Basics



Step by Step Into MPLS – VRF LITE

Although VRF (virtual routing and forwarding) is not actually part of the MPLS you can think of the VRF as a helper for the MPLS in achieving the MPLS VPN infrastructure, now as I would like to make that a very simple to understand guide , I will address here only the VRF part without any MPLS, also known as VRF Lite.
Simple Topology :

R1 Configuration
R2 Configuration
!
ip cef
no ip domain lookup
!
!
ip vrf VRF_GOLD
!
ip vrf VRF_SILVER
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 100
ip vrf forwarding VRF_SILVER
ip address 10.0.0.1 255.255.255.0
!
interface FastEthernet0/0.2
encapsulation dot1Q 200
ip vrf forwarding VRF_GOLD
ip address 20.0.0.1 255.255.255.0
!
!
ip cef
no ip domain lookup
!
ip vrf VRF_GOLD
!
ip vrf VRF_SILVER
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 100
ip vrf forwarding VRF_SILVER
ip address 10.0.0.2 255.255.255.0
!
interface FastEthernet0/0.2
encapsulation dot1Q 200
ip vrf forwarding VRF_GOLD
ip address 20.0.0.2 255.255.255.0
!
!